Skip site navigation (1) Skip section navigation (2)

Site Navigation

FreeBSD/sparc64 Project

Einführung

Diese Seite enthält Information über die Portierung von FreeBSD auf Sun Microsystems UltraSPARC® Architektur. UltraSPARC ist eine Tier 1-Architektur, und als solche vom FreeBSD-Projekt voll unterstützt. Wie dem auch sei, der Port ist nicht so ausgereift wie die vorhandenen i386- oder amd64-Portierungen. Diskussionen über die UltraSPARC Portierung finden auf der Mailingliste freebsd-sparc statt.

Inhaltsverzeichnis

Danksagungen

Die folgenden Personen haben geholfen, die FreeBSD Portierung zu ermöglichen:

Neuigkeiten

  • 25. Oktober 2004: Der CS4231-Audiotreiber wurde von OpenBSD übernommen. Auf SBus-Workstations mit Audio-Hardware (Ultra 1E, Ultra 2) wird nun Audio unterstützt.

  • 9. Oktober 2004: Der auxio-Treiber wurde aus NetBSD importiert.

  • 10. Juni 2004: Der esp-Treiber wurde aus NetBSD importiert. Auf Ultra 1E und Ultra 2 Maschinen wird nun SCSI unterstützt.

  • 18. Januar 2003: Der if_xl Treiber ist ab sofort unterstützt in -CURRENT.

  • 10. Dezember 2002: Tägliche Snapshots von 5.0-CURRENT sind ab sofort auf ftp2.FreeBSD.org verfügbar.

Hardware-Liste

Unten finden Sie eine Liste der unterstützten Systeme. SMP funktioniert auf allen unterstützten Systemen, die mehr als einen Prozessor besitzen. Alle Einzelheiten entnehmen Sie bitte den Hinweisen der benutzten Release.

  • Blade 100
  • Blade 150
  • Enterprise 220R
  • Enterprise 250
  • Enterprise 420R
  • Enterprise 450
  • Fire V100
  • Fire V120
  • Netra™ T1 105
  • Netra T1 AC200/DC200
  • Netra t 1100
  • Netra t 1200
  • Netra t 1125
  • Netra t 1400/1405
  • Netra 120
  • Netra X1
  • SPARCEngine® Ultra Axi
  • SPARCEngine Ultra AXmp
  • Ultra 1E
  • Ultra 2
  • Ultra™ 5
  • Ultra 10
  • Ultra 30
  • Ultra 60
  • Ultra 80

Die folgenden Systeme werden unterstützt, können jedoch nur über das Netzwerk gestartet werden, da der OnBoard SCSI-Controller nicht unterstützt wird. Es wird daran gearbeitet. Es kann sein, dass diese Systeme mit dem esp-Treiber von NetBSD starten.

  • Enterprise 3500
  • Enterprise 4500

Folgende Systeme werden nicht unterstützt:

  • Alle Systeme mit UltraSPARC III oder besseren Prozessor.
  • Ultra 1

Jedes System, welches hier nicht angeführt ist, und keinen UltraSPARC III oder besseren Prozessor hat, sollte funktionieren, wurde aber noch nicht getestet. Haben Sie ein System, welches hier nicht angeführt ist, lassen Sie uns dies bitte wissen.

Was noch getan werden muss

  • Diese Webseite öfter aktualisieren.

Weiterführende Information